aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-10-19 15:26:55 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-19 15:56:23 +0200
commitbae89583827501db4038bffbd9b4bc863e17571d (patch)
treec56011a33027fc9bcd993a0dbc41b2e097316d0f
parent63d4873b9300693ddcbcb6b220b2e892588b83b4 (diff)
downloadguix-bae89583827501db4038bffbd9b4bc863e17571d.tar
guix-bae89583827501db4038bffbd9b4bc863e17571d.tar.gz
gnu: python-typed-ast: Update to 1.4.0.
* gnu/packages/python-xyz.scm (python-typed-ast): Update to 1.4.0, [source]: switch to git-fetch.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 29834257cf..fb6470ef5f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14735,14 +14735,16 @@ source bytes using the UTF-8 encoding and then rewrites Python 3.6 style
(define-public python-typed-ast
(package
(name "python-typed-ast")
- (version "1.3.5")
+ (version "1.4.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "typed-ast" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/python/typed_ast.git")
+ (commit version)))
(sha256
- (base32
- "1m7pr6qpana3cvqwiw7mlvrgvmw27ch5mx1592572xhlki8g85ak"))))
+ (base32 "0l0hz809f7i356kmqkvfsaswiidb98j9hs9rrjnfawzqcbffzgyb"))
+ (file-name (git-file-name name version))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build utils)