aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-15 09:37:59 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-15 14:25:42 +0200
commitba42a6bfc413f0398a3f33a5580059896debd69f (patch)
tree4d5ee94816b4fb34daa1577fb54008472be91e6b
parent93beace0e096ba28989a7ed18ffa731e560a9c77 (diff)
downloadguix-ba42a6bfc413f0398a3f33a5580059896debd69f.tar
guix-ba42a6bfc413f0398a3f33a5580059896debd69f.tar.gz
gnu: Add python-jinja2-time.
* gnu/packages/python-xyz.scm (python-jinja2-time): New public variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d555512ed7..f924aafc92 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -66,6 +66,7 @@
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2495,6 +2496,30 @@ written in pure Python.")
(define-public python2-jinja2
(package-with-python2 python-jinja2))
+(define-public python-jinja2-time
+ (package
+ (name "python-jinja2-time")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jinja2-time" version))
+ (sha256
+ (base32
+ "0h0dr7cfpjnjj8bgl2vk9063a53649pn37wnlkd8hxjy656slkni"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-arrow" ,python-arrow)
+ ("python-jinja2" ,python-jinja2)))
+ (home-page
+ "https://github.com/hackebrot/jinja2-time")
+ (synopsis "Jinja2 Extension for Dates and Times")
+ (description
+ "This package provides an extension for the template engine Jinja2. It
+adds a 'now' tag providing a convenient access to the arrow.now() API from
+templates. A format string can be provided to control the output.")
+ (license license:expat)))
+
(define-public python-pystache
(package
(name "python-pystache")