aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-19 17:52:55 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-20 00:31:16 +0200
commitae5c63d73f98e6ccdb8905f2f69c563a53fc1ab9 (patch)
tree34a66c5a9c8ad75762da58c0776f24bac69791af
parent9d731fb61d745650f5e05c3cb9b82571cf548990 (diff)
downloadguix-ae5c63d73f98e6ccdb8905f2f69c563a53fc1ab9.tar
guix-ae5c63d73f98e6ccdb8905f2f69c563a53fc1ab9.tar.gz
gnu: OpenEXR: Disable failing test on 32-bit systems.
* gnu/packages/graphics.scm (openexr)[arguments]: Patch out one more test. While at it, simplify substitutions, and enable them on 64-bit systems.
-rw-r--r--gnu/packages/graphics.scm30
1 files changed, 19 insertions, 11 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index e453d9fa5b..db328bc685 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -433,23 +433,31 @@ graphics.")
#t))))
(build-system cmake-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'change-directory
(lambda _
(chdir "OpenEXR")
#t))
- (add-after 'change-directory 'disable-broken-test
- ;; This test fails on i686. Upstream developers suggest that
- ;; this test is broken on i686 and can be safely disabled:
- ;; https://github.com/openexr/openexr/issues/67#issuecomment-21169748
+ (add-before 'check 'increase-test-timeout
(lambda _
- (substitute* "IlmImfTest/main.cpp"
- (("#include \"testOptimizedInterleavePatterns.h\"")
- "//#include \"testOptimizedInterleavePatterns.h\"")
- (("TEST \\(testOptimizedInterleavePatterns")
- "//TEST (testOptimizedInterleavePatterns"))
- #t)))))
+ ;; On armhf-linux, we need to override the CTest default
+ ;; timeout of 1500 seconds for the OpenEXR.IlmImf test.
+ (setenv "CTEST_TEST_TIMEOUT" "2000")
+ #t))
+ ,@(if (not (target-64bit?))
+ `((add-after 'change-directory 'disable-broken-test
+ ;; This test fails on i686. Upstream developers suggest that
+ ;; this test is broken on i686 and can be safely disabled:
+ ;; https://github.com/openexr/openexr/issues/67#issuecomment-21169748
+ (lambda _
+ (substitute* "IlmImfTest/main.cpp"
+ ((".*testOptimizedInterleavePatterns.*") "")
+ ;; This test is broken in 2.4.0 and will be fixed in a later
+ ;; release: <https://github.com/openexr/openexr/issues/571>.
+ ((".*testLargeDataWindowOffsets.*") ""))
+ #t)))
+ '()))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(propagated-inputs