aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-10-19 15:21:35 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-19 15:56:23 +0200
commita0b2accf8217f15480272bef2e61fc0407afbcbd (patch)
treecb68492e39b3deb68a95428389b15372e8d0fb32
parent5f760515c86ebdb5fae8524097b3ad35204d734d (diff)
downloadguix-a0b2accf8217f15480272bef2e61fc0407afbcbd.tar
guix-a0b2accf8217f15480272bef2e61fc0407afbcbd.tar.gz
gnu: Add python-setuptools-scm-3.3.
* gnu/packages/python-xyz.scm (python-setuptools-scm-3.3): New variable.
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f27fa4f871..4c46bdca47 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -38,7 +38,7 @@
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
;;; Copyright © 2017, 2018 Adriano Peluso <catonano@gmail.com>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
-;;; Copyright © 2017, 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2017, 2018, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018 Kei Kebreau <kkebreau@posteo.net>
@@ -5111,6 +5111,18 @@ child application and control it as if a human were typing commands.")
them as the version argument or in a SCM managed file.")
(license license:expat)))
+;; Needed by python-lazy-object-proxy, remove on next update cycle.
+(define-public python-setuptools-scm-3.3
+ (package
+ (inherit python-setuptools-scm)
+ (version "3.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "setuptools_scm" version))
+ (sha256
+ (base32
+ "19cyndx23xmpbhz4qrwmfwsmnnaczd0dw7qg977ksq2dbvxy29dx"))))))
+
(define-public python2-setuptools-scm
(package-with-python2 python-setuptools-scm))