aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-10-20 08:18:34 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-20 08:21:07 +0200
commit7757f44044926d1aaa3a9520c5ee6f841d68f58e (patch)
treeb5e94f238c72db6a1f2c610e8eafa99f1ec88177
parentf19e571c970ee40902bab1fea3c8654a73caf02f (diff)
downloadguix-7757f44044926d1aaa3a9520c5ee6f841d68f58e.tar
guix-7757f44044926d1aaa3a9520c5ee6f841d68f58e.tar.gz
gnu: obnam: Remove this package.
This package is abandoned and does not build anymore due to dependencies to old versions of python packages such as pylint. * gnu/packages/backup.scm (obnam): Remove variable.
-rw-r--r--gnu/packages/backup.scm58
1 files changed, 1 insertions, 57 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index a92c8c9aca..a4a087728f 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -711,63 +712,6 @@ NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
license:lgpl3+
license:cc0))))
-(define-public obnam
- (package
- (name "obnam")
- (version "1.21")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://code.liw.fi/debian/pool/main/o/obnam/obnam_"
- version ".orig.tar.xz"))
- (sha256
- (base32
- "0qlipsq50hca71zc0dp1mg9zs12qm0sbblw7qfzl0hj6mk2rv1by"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (substitute* "obnamlib/vfs_local_tests.py"
- ;; Check for the nobody user instead of root.
- (("self.fs.get_username\\(0\\), 'root'")
- "self.fs.get_username(65534), 'nobody'")
- ;; Disable tests checking for root group.
- (("self.fs.get_groupname\\(0\\)") "'root'"))
- (substitute* "obnamlib/vfs_local.py"
- ;; Don't cover get_groupname function.
- (("def get_groupname\\(self, gid\\):")
- "def get_groupname(self, gid): # pragma: no cover"))
- ;; Can't run network tests.
- (invoke "./check" "--unit-tests"))))))
- (inputs
- `(("python2-cliapp" ,python2-cliapp)
- ("python2-larch" ,python2-larch)
- ("python2-paramiko" ,python2-paramiko)
- ("python2-pyaml" ,python2-pyaml)
- ("python2-tracing" ,python2-tracing)
- ("python2-ttystatus" ,python2-ttystatus)))
- (native-inputs
- `(("gnupg" ,gnupg)
- ("python2-coverage" ,python2-coverage)
- ("python2-coverage-test-runner" ,python2-coverage-test-runner)
- ("python2-pep8" ,python2-pep8)
- ("python2-pylint" ,python2-pylint)))
- (home-page "https://obnam.org/")
- (synopsis "Retired backup program")
- (description
- "Warning: @uref{https://blog.liw.fi/posts/2017/08/13/retiring_obnam/,
-the Obnam project is retired}. You should use another backup solution instead.
-
-Obnam was an easy, secure backup program. Features included snapshot backups,
-data de-duplication and encrypted backups using GnuPG. Backups can be stored on
-local hard disks, or online via the SSH SFTP protocol. The backup server, if
-used, does not require any special software, on top of SSH.")
- (license license:gpl3+)))
-
(define-public dirvish
(package
(name "dirvish")