aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-10-19 22:46:44 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-19 22:49:53 +0200
commit1760c970639d898e3ddec4185119a9bda8b663a6 (patch)
tree222522c7a108a3d638502905c51ecae69533ffae
parent6862c0380883c1369ad94a01ddcb8f8e420a49d6 (diff)
downloadguix-1760c970639d898e3ddec4185119a9bda8b663a6.tar
guix-1760c970639d898e3ddec4185119a9bda8b663a6.tar.gz
gnu: python-verboselogs: Fix build.
* gnu/packages/python-xyz.scm (python-verboselogs)[arguments]: Do not run pylint plugin test that depend of an old version of astroid and also remove ..., [native-inputs]: ... python-astroid and python-pylint from here.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0c1479d411..e81a6b838a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -910,10 +910,18 @@ some helpful Python 2 compatibility convenience methods.")
(base32
"09z4d1jiasn7k1hs5af2ckmnrd0i1d1m04bhfjhv7z6svzfdwgg3"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; Do not run pylint plugin test, as astroid is an old
+ ;; unsupported version.
+ (invoke "pytest" "-v" "-k" "not test_pylint_plugin"
+ "verboselogs/tests.py"))))))
(native-inputs
`(("python-mock" ,python-mock)
- ("python-astroid" ,python-astroid)
- ("python-pylint" ,python-pylint)))
+ ("python-pytest" ,python-pytest)))
(home-page "https://verboselogs.readthedocs.io")
(synopsis "Verbose logging level for Python's logging module")
(description