aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-10-19 15:33:03 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-19 15:56:24 +0200
commit10511c415f4681a5f691066c86d949600835db1e (patch)
tree5db6a3d7daf8c957445f098e89fbc146f0397c40
parent741f98b3f1d66252ce0122aed9f800da6bdaa8f7 (diff)
downloadguix-10511c415f4681a5f691066c86d949600835db1e.tar
guix-10511c415f4681a5f691066c86d949600835db1e.tar.gz
gnu: python-pylint: Update to 2.3.1.
* gnu/packages/check.scm (python-pylint): Update to 2.3.1, [source]: switch to git-fetch, [arguments]: remove python2 specific hack to fix unit tests.
-rw-r--r--gnu/packages/check.scm33
1 files changed, 10 insertions, 23 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6a48c08064..d0183d8ad2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
-;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
@@ -1703,19 +1703,22 @@ unit tests and failing them if the unit test module does not exercise all
statements in the module it tests.")
(license license:gpl3+)))
+;; Further releases, up to 2.4.3, have failing unit tests. See:
+;; https://github.com/PyCQA/pylint/issues/3198.
(define-public python-pylint
(package
(name "python-pylint")
- (version "1.7.2")
+ (version "2.3.1")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/PyCQA/pylint/archive/pylint-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PyCQA/pylint")
+ (commit (string-append "pylint-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0mzn1czhf1mgr2wiqfihb274sja02h899b85kywdpivppa9nwrmp"))))
+ "17vvzbcqmkhr4icq5p3737nbiiyj1y3g1pa08n9mb1bsnvxmqq0z"))))
(build-system python-build-system)
(native-inputs
`(("python-pytest" ,python-pytest)
@@ -1726,22 +1729,6 @@ statements in the module it tests.")
("python-isort" ,python-isort)
("python-mccabe" ,python-mccabe)
("python-six" ,python-six)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- ;; Somehow, tests for python2-pylint
- ;; fail if run from the build directory
- (let ((work "/tmp/work"))
- (mkdir-p work)
- (setenv "PYTHONPATH"
- (string-append (getenv "PYTHONPATH") ":" work))
- (copy-recursively "." work)
- (with-directory-excursion "/tmp"
- (invoke "python" "-m" "unittest" "discover"
- "-s" (string-append work "/pylint/test")
- "-p" "*test_*.py"))))))))
(home-page "https://github.com/PyCQA/pylint")
(synopsis "Python source code analyzer which looks for coding standard
errors")