aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-25 14:27:32 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-17 23:04:29 +0000
commitc4d2cffae7e8d6420dd7bd1fd19d31ddab89c101 (patch)
treeedf058def677d4c43be1c1d1193849abe603909b
parent95bd9f65a8ee64d17707a76aebc8720bbd961b68 (diff)
downloadguix-c4d2cffae7e8d6420dd7bd1fd19d31ddab89c101.tar
guix-c4d2cffae7e8d6420dd7bd1fd19d31ddab89c101.tar.gz
gnu: Add go-github-com-tj-docopt.
* gnu/packages/golang.scm (go-github-com-tj-docopt): New variable.
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 20a8c538be..92e612d34b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -639,3 +640,27 @@ termination.")
per-goroutine.")
(home-page "https://github.com/jtolds/gls")
(license license:expat)))
+
+(define-public go-github-com-tj-docopt
+ (package
+ (name "go-github-com-tj-docopt")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tj/docopt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06h8hdg1mh3s78zqlr01g4si7k0f0g6pr7fj7lnvfg446hgc7080"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/tj/docopt"))
+ (synopsis "Go implementation of docopt")
+ (description
+ "This library allows the user to define a command-line interface from a
+program's help message rather than specifying it programatically with
+command-line parsers.")
+ (home-page "https://github.com/tj/docopt")
+ (license license:expat)))