aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-25 14:30:46 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-17 23:04:29 +0000
commitbe5ed142135e939cd23fcfe88c553fd28b32ac53 (patch)
treec8e0f21c78f39df189c630df502c5e430aeae1e5
parented0c6a768ee84fadfc88d3701fbbee982fa033a5 (diff)
downloadguix-be5ed142135e939cd23fcfe88c553fd28b32ac53.tar
guix-be5ed142135e939cd23fcfe88c553fd28b32ac53.tar.gz
gnu: Add terraform-docs.
* gnu/packages/terraform.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/terraform.scm52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f27565bb29..dfb3073d7a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -411,6 +411,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/tcl.scm \
%D%/packages/telephony.scm \
%D%/packages/terminals.scm \
+ %D%/packages/terraform.scm \
%D%/packages/texinfo.scm \
%D%/packages/tex.scm \
%D%/packages/textutils.scm \
diff --git a/gnu/packages/terraform.scm b/gnu/packages/terraform.scm
new file mode 100644
index 0000000000..71b214ed0a
--- /dev/null
+++ b/gnu/packages/terraform.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages terraform)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system go)
+ #:use-module (gnu packages golang))
+
+(define-public terraform-docs
+ (package
+ (name "terraform-docs")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/segmentio/terraform-docs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xchpik32ab8m89s6jv671vswg8xhprfvh6s5md0zd36482d2nmm"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-github-com-hashicorp-hcl" ,go-github-com-hashicorp-hcl)
+ ("go-github-com-tj-docopt" ,go-github-com-tj-docopt)))
+ (arguments
+ '(#:import-path "github.com/segmentio/terraform-docs"))
+ (synopsis "Generate documentation from Terraform modules")
+ (description
+ "The @code{terraform-docs} utility can generate documentation describing
+the inputs and outputs for modules of the Terraform infrastructure management
+tool. These can be shown, or written to a file in JSON or Markdown formats.")
+ (home-page "https://github.com/segmentio/terraform-docs")
+ (license license:expat)))