aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-16 16:44:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-17 16:37:26 +0100
commit9bc0591bc11190ac49c8ea3cf44c4903c924f6c7 (patch)
tree266d2f7e365fde7d61439def013356232a0e49fd
parent8696fbbad1904e6c5edb59f334f9d9ab7ddeeba7 (diff)
downloadguix-9bc0591bc11190ac49c8ea3cf44c4903c924f6c7.tar
guix-9bc0591bc11190ac49c8ea3cf44c4903c924f6c7.tar.gz
gnu: shaderc: Use more standard keys.
* gnu/packages/vulkan.scm (shaderc)[arguments]: Move cmake options from the raw INVOKE call to #:build-type and #:configure-flags. Adjust the ‘configure’ phase accordingly.
-rw-r--r--gnu/packages/vulkan.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 6ba9b94a3d..dc73ce3cad 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -225,11 +225,18 @@ and the ICD.")
"0b41inb1czxv3mciip0lfdxv19ccx2ys31fivfywjn2q8va1gd1f"))))
(build-system meson-build-system)
(arguments
- `(#:tests? #f ; tests don't work yet.
+ `(#:build-type "Release"
+ #:configure-flags
+ (list "-GNinja"
+ "-DSHADERC_SKIP_TESTS=ON"
+ "-DCMAKE_INSTALL_LIBDIR=lib"
+ (string-append "-DCMAKE_INSTALL_PREFIX="
+ (assoc-ref %outputs "out")))
+ #:tests? #f ; tests don't work yet.
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key build-type configure-flags #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
;; Remove various lines and touch build-version.inc or
;; configuring won't work.
@@ -247,11 +254,8 @@ and the ICD.")
(substitute* "CMakeLists.txt" ((".*--check.*") ""))
(substitute* "glslc/src/main.cc" ((".*build-version.inc.*")
"\"1\""))
- (invoke "cmake" "-GNinja" "-DCMAKE_BUILD_TYPE=Release"
- "-DSHADERC_SKIP_TESTS=ON"
- "-DCMAKE_INSTALL_LIBDIR=lib"
- (string-append "-DCMAKE_INSTALL_PREFIX="
- out)))))
+ (invoke "cmake" (cons build-type configure-flags))
+ #t)))
(add-after 'unpack 'unpack-sources
(lambda* (#:key inputs #:allow-other-keys)
(let ((spirv-tools-source (assoc-ref %build-inputs