aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:45:21 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 10:23:52 +0000
commit670ee20a57a4417f34458bb489f717378077e2ae (patch)
treefaa721f0b2b3340b506dfa93b86ee3de732535b1
parentd64ebebd8e91688d1f86fff72c7a133b4be09921 (diff)
downloadguix-670ee20a57a4417f34458bb489f717378077e2ae.tar
guix-670ee20a57a4417f34458bb489f717378077e2ae.tar.gz
gnu: Add ruby-rake.
* gnu/packages/ruby.scm (ruby-rake): New variable.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4131529afe..703ca37aa0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4911,3 +4911,24 @@ thing this library does today is convert org-mode files to HTML or Textile or
Markdown.")
(home-page "https://github.com/wallyqs/org-ruby")
(license license:expat)))
+
+(define-public ruby-rake
+ (package
+ (name "ruby-rake")
+ (version "12.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rake" version))
+ (sha256
+ (base32
+ "190p7cs8zdn07mjj6xwwsdna3g0r98zs4crz7jh2j2q5b0nbxgjf"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis "Rake is a Make-like program implemented in Ruby")
+ (description
+ "Rake is a Make-like program where tasks and dependencies are specified
+in standard Ruby syntax.")
+ (home-page "https://github.com/ruby/rake")
+ (license license:expat)))