aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-17 12:23:59 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-17 16:37:28 +0100
commit3def739da13a166769777d0db7baba79230f64ae (patch)
tree32971aa5389fcdf8fe4de53790bd14e3a63aeffb
parentc695fb769c94623371c5997da1dc454b0a4f58a8 (diff)
downloadguix-3def739da13a166769777d0db7baba79230f64ae.tar
guix-3def739da13a166769777d0db7baba79230f64ae.tar.gz
gnu: Use the CMake build system's #:build-type key.
* gnu/packages/code.scm (rtags)[arguments]: Move the CMAKE_BUILD_TYPE from #:configure-flags to #:build-type. * gnu/packages/databases.scm (apache-arrow)[arguments]: Likewise * gnu/packages/engineering.scm (kicad)[arguments]: Likewise * gnu/packages/flashing-tools.scm (heimdall)[arguments]: Likewise * gnu/packages/graphics.scm (openscenegraph)[arguments]: Likewise * gnu/packages/linux.scm (rdma-core)[arguments]: Likewise * gnu/packages/music.scm (portmidi)[arguments]: Likewise * gnu/packages/photo.scm (rawtherapee)[arguments]: Likewise * gnu/packages/rdesktop.scm (freerdp)[arguments]: Likewise * gnu/packages/serialization.scm (flatbuffers)[arguments]: Likewise * gnu/packages/web.scm (tidy-html)[arguments]: Likewise
-rw-r--r--gnu/packages/code.scm4
-rw-r--r--gnu/packages/databases.scm4
-rw-r--r--gnu/packages/engineering.scm2
-rw-r--r--gnu/packages/flashing-tools.scm4
-rw-r--r--gnu/packages/graphics.scm13
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/packages/music.scm4
-rw-r--r--gnu/packages/photo.scm2
-rw-r--r--gnu/packages/rdesktop.scm7
-rw-r--r--gnu/packages/serialization.scm8
-rw-r--r--gnu/packages/web.scm6
11 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 979c7a72b8..15fdf9d66f 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -420,9 +420,9 @@ functionality such as HTML output.")
"0scjbp1z201q8njvrxqz7lk2m9b6k2rxd5q1shrng6532r7ndif2"))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags
+ '(#:build-type "RelWithDebInfo"
+ #:configure-flags
'("-DRTAGS_NO_ELISP_FILES=1"
- "-DCMAKE_BUILD_TYPE=RelWithDebInfo"
"-DCMAKE_CXX_FLAGS=-std=c++11"
"-DBUILD_TESTING=FALSE")
#:tests? #f))
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 58da1f7a90..bcf1864775 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2771,9 +2771,9 @@ Monitor read/write activity on a mongo server
(setenv "JEMALLOC_HOME" (assoc-ref %build-inputs "jemalloc"))
(setenv "RAPIDJSON_HOME" (assoc-ref %build-inputs "rapidjson"))
#t)))
+ #:build-type "Release"
#:configure-flags
- (list "-DCMAKE_BUILD_TYPE=Release"
- "-DARROW_PYTHON=ON"
+ (list "-DARROW_PYTHON=ON"
;; Install to PREFIX/lib (the default is
;; PREFIX/lib64).
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 076d4b6094..4d45aab772 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -696,12 +696,12 @@ language.")
(arguments
`(#:out-of-source? #t
#:tests? #f ; no tests
+ #:build-type "Release"
#:configure-flags
(list "-DKICAD_STABLE_VERSION=ON"
"-DKICAD_REPO_NAME=stable"
,(string-append "-DKICAD_BUILD_VERSION=4.0-"
(string-take commit 7))
- "-DCMAKE_BUILD_TYPE=Release"
"-DKICAD_SKIP_BOOST=ON"; Use our system's boost library.
"-DKICAD_SCRIPTING=ON"
"-DKICAD_SCRIPTING_MODULES=ON"
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 51b259a5cf..36c8353ee0 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -300,8 +300,8 @@ RK3036, RK3066, RK312X, RK3168, RK3188, RK3288, RK3368.")
"1y7gwg3lipyp2zcysm2vid1qg5nwin9bxbvgzs28lz2rya4fz6sq"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
- #:tests? #f; no tests
+ `(#:build-type "Release"
+ #:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-invocations
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 8ea9c74cec..d2f1b3b0b8 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -423,15 +423,14 @@ visual effects work for film.")
(file-name (string-append name "-" version ".zip"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;; No test target available.
+ `(#:tests? #f ; no test target available
+ ;; Without this flag, 'rd' will be added to the name of the
+ ;; library binaries and break linking with other programs.
+ #:build-type "Release"
#:configure-flags
(list (string-append "-DCMAKE_INSTALL_RPATH="
(assoc-ref %outputs "out") "/lib:"
- (assoc-ref %outputs "out") "/lib64")
- ;; We need to set this flag or otherwise 'rd' will be added
- ;; to the name of the library binaries and break linking
- ;; with other programs.
- "-DCMAKE_BUILD_TYPE=Release")))
+ (assoc-ref %outputs "out") "/lib64"))))
(native-inputs
`(("unzip" ,unzip)))
(inputs
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a268c4db0d..b7e70249f3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3404,8 +3404,8 @@ The package provides additional NTFS tools.")
;; Upstream uses the "ninja" build system and encourage distros
;; to do the same for consistency. They also recommend using the
;; "Release" build type.
- #:configure-flags (list "-GNinja"
- "-DCMAKE_BUILD_TYPE=Release")
+ #:build-type "Release"
+ #:configure-flags (list "-GNinja")
#:phases
(modify-phases %standard-phases
(replace 'build
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c7c4913bf0..7818cfcc0b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1754,10 +1754,10 @@ projects.")
(patches (list (search-patch "portmidi-modular-build.patch")))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; tests cannot be linked
+ `(#:tests? #f ; tests cannot be linked
+ #:build-type "Release" ; needed to have PMALSA set
#:configure-flags
(list "-DPORTMIDI_ENABLE_JAVA=Off"
- "-DCMAKE_BUILD_TYPE=Release" ; needed to have PMALSA set
"-DPORTMIDI_ENABLE_TEST=Off"))) ; tests fail linking
(inputs
`(("alsa-lib" ,alsa-lib)))
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 758ed3f6f1..90bc365d05 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -481,11 +481,11 @@ a complete panorama and stitch any series of overlapping pictures.")
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no test suite
+ #:build-type "release"
#:configure-flags
(list (string-append "-DLENSFUNDBDIR="
(assoc-ref %build-inputs "lensfun")
"/share/lensfun")
- "-DCMAKE_BUILD_TYPE=release"
; Don't optimize the build for the host machine. See the file
; 'ProcessorTargets.cmake' in the source distribution for more
; information.
diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index 1a2d0412d1..bd2b5737e9 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -111,9 +112,9 @@ to remotely control a user's Windows desktop.")
("zlib" ,zlib)
("openssl" ,openssl)))
(arguments
- `(#:configure-flags
- (list "-DCMAKE_BUILD_TYPE=RELEASE"
- "-DWITH_JPEG=ON"
+ `(#:build-type "RELEASE"
+ #:configure-flags
+ (list "-DWITH_JPEG=ON"
,@(if (string-prefix? "x86_64"
(or (%current-target-system)
(%current-system)))
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 3dd3a070e4..f721165751 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
;;; Copyright © 2017 ng0 <ng0@infotropique.org>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;;
;;; This file is part of GNU Guix.
@@ -431,10 +431,10 @@ to generate and parse. The two primary functions are @code{cbor.loads} and
"0blc978wc5h91662vai24xj92c3bx56y6hzid90qva7il302jl64"))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags
+ '(#:build-type "Release"
+ #:configure-flags
(list (string-append "-DCMAKE_INSTALL_LIBDIR="
- (assoc-ref %outputs "out") "/lib")
- "-DCMAKE_BUILD_TYPE=Release")))
+ (assoc-ref %outputs "out") "/lib"))))
(home-page "https://google.github.io/flatbuffers/")
(synopsis "Memory-efficient serialization library")
(description "FlatBuffers is a cross platform serialization library for C++,
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 394fa7b71c..625df2b1dc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4971,10 +4971,10 @@ used to start services with both privileged and non-privileged port numbers.")
"0n29wcgw32rhnraj9j21ibhwi0xagmmcskhbaz8ihxly7nx3p9h8"))))
(build-system cmake-build-system)
(outputs '("out"
- "static")) ; 1.0MiB of .a files
+ "static")) ; 1.0MiB of .a files
(arguments
- `(#:tests? #f ; No tests available
- #:configure-flags (list "-DCMAKE_BUILD_TYPE=Release")
+ `(#:tests? #f ; no tests available
+ #:build-type "Release"
#:phases
(modify-phases %standard-phases
(add-after 'install 'move-static-libraries