aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-08-01 07:42:06 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 21:12:11 +0100
commitdd3f344ccae0efb9b67dadf785b93713f4d8d251 (patch)
treed88518b657d836aac0675ef4fad179431e58a743
parentce2ad5f1c5bb671ddd001e22a48bfb4a3816c8e3 (diff)
downloadguix-dd3f344ccae0efb9b67dadf785b93713f4d8d251.tar
guix-dd3f344ccae0efb9b67dadf785b93713f4d8d251.tar.gz
gnu: Add ruby-github-api.
* gnu/packages/ruby.scm (ruby-github-api): New variable.
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 43948ee854..be2f92f4e9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2777,6 +2777,35 @@ use GNU gettext tools for maintenance.")
(home-page "https://ruby-gettext.github.com/")
(license (list license:lgpl3+ license:ruby))))
+(define-public ruby-github-api
+ (package
+ (name "ruby-github-api")
+ (version "0.18.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "github_api" version))
+ (sha256
+ (base32
+ "04x8mlvinl17wfw6r71c9jbh7g78ziiwvsqv20ylyjzybr7x0w6s"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-addressable" ,ruby-addressable)
+ ("ruby-descendants-tracker"
+ ,ruby-descendants-tracker)
+ ("ruby-faraday" ,ruby-faraday)
+ ("ruby-hashie" ,ruby-hashie)
+ ("ruby-oauth2" ,ruby-oauth2)))
+ (synopsis
+ " Ruby client that supports all of the GitHub API methods. It's build in a modular way, that is, you can either instantiate the whole api wrapper Github.new or use parts of it e.i. Github::Client::Repos.new if working solely with repositories is your main concern. Intuitive query methods allow you easily call API endpoints. ")
+ (description
+ " Ruby client that supports all of the GitHub API methods. It's build in a modular way, that is, you can either instantiate the whole api wrapper Github.new or use parts of it e.i. Github::Client::Repos.new if working solely with repositories is your main concern. Intuitive query methods allow you easily call API endpoints. ")
+ (home-page
+ "http://piotrmurach.github.io/github/")
+ (license license:expat)))
+
(define-public ruby-packnga
(package
(name "ruby-packnga")