aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:45:41 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 21:12:11 +0100
commitc7fe4178efb448c9a0aa6c65f4066e7cc1be06ba (patch)
treeee271d6299aa0acaf5fb6b1ad4edbeb7088e9859
parentda722b6244095184936d0d021574c1c1f9b3387a (diff)
downloadguix-c7fe4178efb448c9a0aa6c65f4066e7cc1be06ba.tar
guix-c7fe4178efb448c9a0aa6c65f4066e7cc1be06ba.tar.gz
gnu: Add ruby-appraisal.
-rw-r--r--gnu/packages/ruby.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1091566c7e..d1cb63e55f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -874,6 +874,45 @@ configuration, and more.")
(home-page "http://log4r.rubyforge.org/")
(license license:bsd-3)))
+(define-public ruby-appraisal
+ (package
+ (name "ruby-appraisal")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "appraisal" version))
+ (sha256
+ (base32
+ "10ng010lhswdykjhwic7bgv28qpjj42qwxvprpj1f4cavdimh4vp"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f ; tests require network access
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ ;; remove bundler from Rakefile to avoid dependency issues
+ (add-before 'check 'remove-dependency-checking
+ (lambda _
+; (substitute* "Rakefile"
+ ; (("^require 'bundler.*") ""))
+ (substitute* "Gemfile"
+ (("thor.*") "thor'\n"))
+ #t)))))
+ (propagated-inputs
+ `(("bundler" ,bundler)
+ ("ruby-thor" ,ruby-thor)))
+ (native-inputs
+ `(("ruby-activesupport" ,ruby-activesupport)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis
+ "Appraisal integrates with bundler and rake to test your library against different versions of dependencies in repeatable scenarios called \"appraisals.\"")
+ (description
+ "Appraisal integrates with bundler and rake to test your library against different versions of dependencies in repeatable scenarios called \"appraisals.\"")
+ (home-page
+ "http://github.com/thoughtbot/appraisal")
+ (license license:expat)))
+
(define-public ruby-atoulme-antwrap
(package
(name "ruby-atoulme-antwrap")