aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-04-14 19:09:08 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 19:42:20 +0100
commitb0221ab31231d95adcc07e2e0d986033d1bbf445 (patch)
treec8348fb7b1f1e2ef832d6fab4e935bfd01a5a7aa
parent29dd48c6cd3115ff31c35d86d6347ec48f54d703 (diff)
downloadguix-b0221ab31231d95adcc07e2e0d986033d1bbf445.tar
guix-b0221ab31231d95adcc07e2e0d986033d1bbf445.tar.gz
gnu: Add ruby-kgio.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 277a2c0a7b..eb2b9f5719 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8179,6 +8179,33 @@ functionality from Prawn.")
(description "This gem provides tables support for Prawn.")
(license license:gpl3+)))
+(define-public ruby-kgio
+ (package
+ (name "ruby-kgio")
+ (version "2.11.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "kgio" version))
+ (sha256
+ (base32
+ "1528pyj1szzzp3pgj05fzjd36qjrxm9yj2x5radc9p1z7vl67y50"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "This is a legacy project, do not use it for new projects. Ruby
+2.3 and later should make this obsolete. kgio provides
+non-blocking I/O methods for Ruby without raising exceptions on
+EAGAIN and EINPROGRESS.")
+ (description
+ "This is a legacy project, do not use it for new projects. Ruby
+2.3 and later should make this obsolete. kgio provides
+non-blocking I/O methods for Ruby without raising exceptions on
+EAGAIN and EINPROGRESS.")
+ (home-page "https://bogomips.org/kgio/")
+ (license #f)))
+
(define-public ruby-kramdown
(package
(name "ruby-kramdown")