aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 21:15:15 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-28 19:42:22 +0100
commitabcbf60b19801beefe8c6884a5729367323904c1 (patch)
treede80d12cf1aa07a12ee562560eaef74a73477d3b
parent8f58f89c545ab460efb3c2bb4f313c76acb37dd6 (diff)
downloadguix-abcbf60b19801beefe8c6884a5729367323904c1.tar
guix-abcbf60b19801beefe8c6884a5729367323904c1.tar.gz
gnu: ruby-hashie: Enable the tests.
Switch the source to the Git repository so that the tests can be run. * gnu/packages/ruby.scm (ruby-hashie)[source]: Switch to the Git repository. [arguments]: Replace the 'check phase and enable the tests. [native-inputs]: Add ruby-rspec, ruby-rspec-pending-for, ruby-pry and ruby-activesupport.
-rw-r--r--gnu/packages/ruby.scm33
1 files changed, 25 insertions, 8 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d02cfc3f8c..18f8ecacfe 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8510,16 +8510,33 @@ is compatible with stylesheets designed for pygments.")
(package
(name "ruby-hashie")
(version "3.6.0")
- (source (origin
- (method url-fetch)
- (uri (rubygems-uri "hashie" version))
- (sha256
- (base32
- "13bdzfp25c8k51ayzxqkbzag3wj5gc1jd8h7d985nsq6pn57g5xh"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/intridea/hashie.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rrzb25h3apsf8cr40gglvdiiyk2mh1122ix4vgh1ci3yw23z5ax"))))
(build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; Run rspec directly to avoid the extra dependencies needed to
+ ;; evaluate the Rakefile.
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec"))
+ #t)))))
(native-inputs
- `(("bundler" ,bundler)))
- (arguments `(#:tests? #f)); FIXME: Could not locate Gemfile or .bundle/ directory
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-rspec-pending-for" ,ruby-rspec-pending-for)
+ ("ruby-pry" ,ruby-pry)
+ ("ruby-activesupport" ,ruby-activesupport)))
(home-page "https://github.com/intridea/hashie")
(synopsis "Extensions to Ruby Hashes")
(description "Hashie is a collection of classes and mixins that make Ruby