aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-04-14 19:09:36 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 19:42:21 +0100
commit9dd5addebdac0e2d136268e1ffcfadb09ccae0fc (patch)
tree2d331dfbfc48d537f732a500e8819430adefd8b5
parent7492546bb999897673a2658310e45794b80d8474 (diff)
downloadguix-9dd5addebdac0e2d136268e1ffcfadb09ccae0fc.tar
guix-9dd5addebdac0e2d136268e1ffcfadb09ccae0fc.tar.gz
gnu: Add ruby-unicorn.
-rw-r--r--gnu/packages/web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7d8e51b5af..d62284d71e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -59,6 +59,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system ruby)
#:use-module (guix build-system cmake)
#:use-module (guix build-system trivial)
#:use-module (guix build-system python)
@@ -115,6 +116,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages xml)
#:use-module (gnu packages curl)
@@ -785,6 +787,36 @@ current version of any major web browser.")
style API.")
(license l:expat)))
+(define-public ruby-unicorn
+ (package
+ (name "ruby-unicorn")
+ (version "5.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "unicorn" version))
+ (sha256
+ (base32
+ "09s3mdsrc080h7b70lkl2wnv36iy9ipdqbi1ffm3fxd0498xjb7h"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-kgio" ,ruby-kgio)
+ ("ruby-raindrops" ,ruby-raindrops)))
+ (synopsis
+ "unicorn is an HTTP server for Rack applications designed to only serve
+fast clients on low-latency, high-bandwidth connections and take
+advantage of features in Unix/Unix-like kernels. Slow clients should
+only be served by placing a reverse proxy capable of fully buffering
+both the the request and response in between unicorn and slow clients.")
+ (description
+ "unicorn is an HTTP server for Rack applications designed to only serve
+fast clients on low-latency, high-bandwidth connections and take
+advantage of features in Unix/Unix-like kernels. Slow clients should
+only be served by placing a reverse proxy capable of fully buffering
+both the the request and response in between unicorn and slow clients.")
+ (home-page "https://bogomips.org/unicorn/")
+ (license (list #f #f))))
+
(define-public libyajl
(package
(name "libyajl")