aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-08-01 07:39:42 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 21:12:13 +0100
commit9502ae80df7e7cfa5fa6f06728a766b28e8f3998 (patch)
treec03cdff35a4b68392a5905e190ed63df5adfa0ba
parent558c874238890da4d38bafc6e341b8bda6df0e12 (diff)
downloadguix-9502ae80df7e7cfa5fa6f06728a766b28e8f3998.tar
guix-9502ae80df7e7cfa5fa6f06728a766b28e8f3998.tar.gz
gnu: Add ruby-psych.
Required for ruby-jeweler. * gnu/packages/ruby.scm (ruby-psych): New variable.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6e63c6b91e..59510e7163 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4474,6 +4474,34 @@ invocation, and source and documentation browsing.")
(home-page "https://pryrepl.org")
(license license:expat)))
+(define-public ruby-psych
+ (package
+ (name "ruby-psych")
+ (version "3.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "psych" version))
+ (sha256
+ (base32
+ "0g9yrzzfza5yjfnn4pkykr71fhpayahvimvyyv8xi3i34a03v9xg"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis
+ "Psych is a YAML parser and emitter. Psych leverages libyaml[http://pyyaml.org/wiki/LibYAML]
+for its YAML parsing and emitting capabilities. In addition to wrapping libyaml,
+Psych also knows how to serialize and de-serialize most Ruby objects to and from the YAML format.
+")
+ (description
+ "Psych is a YAML parser and emitter. Psych leverages libyaml[http://pyyaml.org/wiki/LibYAML]
+for its YAML parsing and emitting capabilities. In addition to wrapping libyaml,
+Psych also knows how to serialize and de-serialize most Ruby objects to and from the YAML format.
+")
+ (home-page "https://github.com/ruby/psych")
+ (license license:expat)))
+
(define-public ruby-guard
(package
(name "ruby-guard")