aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:11 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 21:12:13 +0100
commit55f0ce31459950a7260eb9089407c1559a3744c1 (patch)
tree024e0bfb3ba766ef5142eaff0cb89a3131c2b41e
parente02219460c6282bf479b8350b1afd88f478e7d2c (diff)
downloadguix-55f0ce31459950a7260eb9089407c1559a3744c1.tar
guix-55f0ce31459950a7260eb9089407c1559a3744c1.tar.gz
gnu: Add ruby-thread-order.
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e3f3006f36..2c41530989 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4687,6 +4687,40 @@ engines in an attempt to make their usage as generic as possible.")
"https://github.com/guard/guard-rspec")
(license license:expat)))
+(define-public ruby-thread-order
+ (package
+ (name "ruby-thread-order")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "thread_order" version))
+ (sha256
+ (base32
+ "1n8zs3m7na5jmpf0pw0z79vg0x0lfzajpynp28zb43l89l00qcfi"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)))
+ (arguments
+ '(;; TODO: 1 test fails
+ ;; 1) ThreadOrder is implemented without depending on the stdlib
+ ;; Failure/Error: expect(loaded_filenames).to_not include 'monitor.rb'
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "rspec")
+ #t))))))
+ (synopsis
+ "Test helper for ordering threaded code (does not depend on gems or stdlib, tested on 1.8.7 - 2.2, rbx, jruby).")
+ (description
+ "Test helper for ordering threaded code (does not depend on gems or stdlib, tested on 1.8.7 - 2.2, rbx, jruby).")
+ (home-page
+ "https://github.com/JoshCheek/thread_order")
+ (license license:expat)))
+
(define-public ruby-thread-safe
(package
(name "ruby-thread-safe")