aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:01:50 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 19:42:24 +0100
commit3dbec348c8fd90def2ff098e1e79cd7ef36cc632 (patch)
tree0edf9ad75143fb6a6729c587409cd1fff29ee5a4
parentef67da7f0e55c24789a2bad52020c908d11018b4 (diff)
downloadguix-3dbec348c8fd90def2ff098e1e79cd7ef36cc632.tar
guix-3dbec348c8fd90def2ff098e1e79cd7ef36cc632.tar.gz
gnu: Add ruby-vcr.
Required for ruby-coveralls.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6aee819263..139284048e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6757,6 +6757,28 @@ display width of strings in Ruby.")
(home-page "https://github.com/janlelis/unicode-display_width")
(license license:expat)))
+(define-public ruby-vcr
+ (package
+ (name "ruby-vcr")
+ (version "3.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "vcr" version))
+ (sha256
+ (base32
+ "1y19gb8vz1rbhx1qhim6kpp0fzksqhd7grb50hmrbjx5h4hc3y0y"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; No Rakefile in gem, and there's likely unpackaged
+ ; dependencies anyway.
+ (synopsis
+ "Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests.")
+ (description
+ "Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests.")
+ (home-page "http://vcr.github.io/vcr")
+ (license license:expat)))
+
;; There is another gem called 'ruby-version' so we use an underscore in this
;; name
(define-public ruby_version