aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:03:29 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 21:12:12 +0100
commit396cb471dc38d7f1da0808bf6980e8057f243f2d (patch)
tree1b5e14e474d91c5c48ee8290dcd331d6b630da5f
parent5dfbdad7e3d52d21087d45053b2651563934fbcc (diff)
downloadguix-396cb471dc38d7f1da0808bf6980e8057f243f2d.tar
guix-396cb471dc38d7f1da0808bf6980e8057f243f2d.tar.gz
gnu: Add ruby-guard-rspec.
-rw-r--r--gnu/packages/ruby.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d7bf3518d5..39538b3954 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4592,6 +4592,49 @@ engines in an attempt to make their usage as generic as possible.")
(home-page "https://github.com/guard/guard-compat")
(license license:expat)))
+(define-public ruby-guard-rspec
+ (package
+ (name "ruby-guard-rspec")
+ (version "4.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "guard-rspec" version))
+ (sha256
+ (base32
+ "1jkm5xp90gm4c5s51pmf92i9hc10gslwwic6mvk72g0yplya0yx4"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; TODO
+ #:tests? #f
+ #:test-target "default"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-unnecessary-dependencies
+ (lambda _
+ (substitute* "Gemfile"
+ ((".*gem \"rubocop\".*") "\n")
+ ((".*gem \"guard-rubocop\".*") "\n"))
+ ;; This means Rubocop won't be used in the Rakefile
+ (substitute* "Rakefile"
+ (("unless Nenv\\.ci\\?") "if false"))
+ #t)))))
+ (propagated-inputs
+ `(("ruby-guard" ,ruby-guard)
+ ("ruby-guard-compat" ,ruby-guard-compat)
+ ("ruby-rspec" ,ruby-rspec)))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-launchy" ,ruby-launchy)
+ ("ruby-gem-isolator" ,ruby-gem-isolator)))
+ (synopsis
+ "Guard::RSpec automatically run your specs (much like autotest).")
+ (description
+ "Guard::RSpec automatically run your specs (much like autotest).")
+ (home-page
+ "https://github.com/guard/guard-rspec")
+ (license license:expat)))
+
(define-public ruby-thread-safe
(package
(name "ruby-thread-safe")