aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:42:08 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 21:12:15 +0100
commit17bc0a7508cf0d1578d10fb8bc430882bf612fde (patch)
tree2a599fa44b0bc4e3e7786a8d49cc8b9900736d47
parent3a4c19fea56fd5c3485bf2f03ab4c4ac08bdd7f8 (diff)
downloadguix-17bc0a7508cf0d1578d10fb8bc430882bf612fde.tar
guix-17bc0a7508cf0d1578d10fb8bc430882bf612fde.tar.gz
gnu: Add ruby-event-bus.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 392c36533a..b29c13c31c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1853,6 +1853,34 @@ a Ruby object.")
(home-page "https://github.com/rails/execjs")
(license license:expat)))
+(define-public ruby-event-bus
+ (package
+ (name "ruby-event-bus")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "event-bus" version))
+ (sha256
+ (base32
+ "0bqcznr15q1346avpddnyd9144hqdww86yfpb4jayaj6lm0fqwyq"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; disable testing to break the cycle with aruba. Instead simply test that
+ ;; the library can be require'd.
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "ruby" "-Ilib" "-r" "event/bus")))))))
+ (synopsis
+ "This gem notifies subscribers about event")
+ (description
+ "This gem notifies subscribers about event")
+ (home-page
+ "https://github.com/cucumber/event-bus")
+ (license license:expat)))
+
(define-public ruby-orderedhash
(package
(name "ruby-orderedhash")