aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:42:19 +0100
committerChristopher Baines <mail@cbaines.net>2019-04-28 19:42:23 +0100
commit175494c833cdefaf268652b5d4bd7e5a5d5bc407 (patch)
treef601eac55d970505827a4d967eee523c17c2872f
parentb3d2d17561ed4aabb9a30a182d909188c1acd125 (diff)
downloadguix-175494c833cdefaf268652b5d4bd7e5a5d5bc407.tar
guix-175494c833cdefaf268652b5d4bd7e5a5d5bc407.tar.gz
gnu: ruby-childprocess: Update to 1.0.1.
* gnu/packages/ruby.scm (ruby-childproces)[arguments]: TODO
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 23 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4f107552fe..8e6240044f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7692,17 +7692,37 @@ in standard Ruby syntax.")
(define-public ruby-childprocess
(package
(name "ruby-childprocess")
- (version "0.6.3")
+ (version "1.0.1")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "childprocess" version))
(sha256
(base32
- "1p3f43scdzx9zxmy2kw5zsc3az6v46nq4brwcxmnscjy4w4racbv"))))
+ "1d2gasf988jh2k3fjb7i54c68rq6ni6jf9w0gnsfhrq94a6mprkz"))))
(build-system ruby-build-system)
(arguments
- `(#:tests? #f))
+ '(;; TODO: Two of the tests fail:
+ ;;
+ ;; ./spec/childprocess_spec.rb:192 # ChildProcess lets a detached child
+ ;; live on
+ ;; ./spec/childprocess_spec.rb:280 # ChildProcess kills the full
+ ;; process tree
+ #:tests? #f
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-unnecessary-dependencies
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ ((".*coveralls.*") "")
+ ((".*Coveralls.*") ""))
+ #t))
+ (add-after 'unpack 'fix-/bin/sh-reference
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ (("/bin/sh") (which "sh")))
+ #t)))))
(native-inputs
`(("bundler" ,bundler)
("ruby-rspec" ,ruby-rspec)))