aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:41 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-28 18:11:11 +0000
commite4f9c2e0f0d08909a85086e0417e1cde9f5b98b6 (patch)
tree21caaaf2f1397b55c654a6504f22b4a69089b035
parente0c93a7dbb03c2dd8846c985154ca740b318641f (diff)
downloadguix-e4f9c2e0f0d08909a85086e0417e1cde9f5b98b6.tar
guix-e4f9c2e0f0d08909a85086e0417e1cde9f5b98b6.tar.gz
gnu: Add ruby-omniauth.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b0a166dec6..f77a33228e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9494,3 +9494,28 @@ way.")
"This package provides a Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
(home-page "http://github.com/intridea/oauth2")
(license license:expat)))
+
+(define-public ruby-omniauth
+ (package
+ (name "ruby-omniauth")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "omniauth" version))
+ (sha256
+ (base32
+ "1msqr4qq7mfdvl3rg89529isrv595hvjpj2gi0say4b8nwqfggmg"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-hashie" ,ruby-hashie)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A generalized Rack framework for multiple-provider authentication.")
+ (description
+ "This package provides a generalized Rack framework for multiple-provider authentication.")
+ (home-page
+ "https://github.com/omniauth/omniauth")
+ (license license:expat)))