aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:33 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-28 18:11:11 +0000
commite0c93a7dbb03c2dd8846c985154ca740b318641f (patch)
treeade80819f714844a7017182dd6045b3ae8432f63
parent199bcae42d58ea25247e4e5ad9710ed1de663608 (diff)
downloadguix-e0c93a7dbb03c2dd8846c985154ca740b318641f.tar
guix-e0c93a7dbb03c2dd8846c985154ca740b318641f.tar.gz
gnu: Add ruby-oauth2.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d7d659dfe7..b0a166dec6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9467,3 +9467,30 @@ way.")
"This package provides a pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
(home-page "http://github.com/jwt/ruby-jwt")
(license license:expat)))
+
+(define-public ruby-oauth2
+ (package
+ (name "ruby-oauth2")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "oauth2" version))
+ (sha256
+ (base32
+ "094hmmfms8vpm6nwglpl7jmlv85nlfzl0kik4fizgx1rg70a6mr5"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-faraday" ,ruby-faraday)
+ ("ruby-jwt" ,ruby-jwt)
+ ("ruby-multi-json" ,ruby-multi-json)
+ ("ruby-multi-xml" ,ruby-multi-xml)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (description
+ "This package provides a Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (home-page "http://github.com/intridea/oauth2")
+ (license license:expat)))