aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:01:26 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 12:29:16 +0000
commitd3644bbf4d4ede73aa14ffe0c72d2ab6de19d2a9 (patch)
tree27cb7da065790eaf38c23cfdc10990242405c51f
parent0750ef20f5a3988a79ea37c9f684ed37893c5f26 (diff)
downloadguix-d3644bbf4d4ede73aa14ffe0c72d2ab6de19d2a9.tar
guix-d3644bbf4d4ede73aa14ffe0c72d2ab6de19d2a9.tar.gz
gnu: Add ruby-heredoc-unindent.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cd5b1db098..2822ae314f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1665,6 +1665,36 @@ standard output stream.")
(home-page "https://github.com/intridea/hashie")
(license license:expat)))
+(define-public ruby-heredoc-unindent
+ (package
+ (name "ruby-heredoc-unindent")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "heredoc_unindent" version))
+ (sha256
+ (base32
+ "14ijr2fsjwhrkjkcaz81d5xnfa4vvgvcflrff83avqw9klm011yw"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)))
+
+ (synopsis
+ "This gem removes common margin from indented strings")
+ (description
+ "This gem removes common margin from indented strings, such as the ones
+produced by indented heredocs. In other words, it strips out leading whitespace
+chars at the beggining of each line, but only as much as the line with the
+smallest margin.
+
+It is acknowledged that many strings defined by heredocs are just code and fact
+is that most parsers are insensitive to indentation. If, however, the strings
+are to be used otherwise, be it for printing or testing, the extra indentation
+will probably be an issue and hence this gem.")
+ (home-page
+ "https://github.com/adrianomitre/heredoc_unindent")
+ (license license:expat)))
(define-public ruby-shindo
(package
(name "ruby-shindo")