aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-18 11:21:17 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-28 18:11:11 +0000
commit8360aa79ed4fca83abccbe8bc02823b103841008 (patch)
tree2d68e7862100d996d519ecc6ea58eafa06638b31
parent2e49e80860f63e953618caddec330c08a4f3745f (diff)
downloadguix-8360aa79ed4fca83abccbe8bc02823b103841008.tar
guix-8360aa79ed4fca83abccbe8bc02823b103841008.tar.gz
gnu: Add ruby-rerun.
* gnu/packages/ruby.scm (ruby-rerun): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 75ed9039b7..9d70161ccc 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9563,3 +9563,26 @@ way.")
(home-page
"https://github.com/opperator/warden-oauth2")
(license #f)))
+
+(define-public ruby-rerun
+ (package
+ (name "ruby-rerun")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rerun" version))
+ (sha256
+ (base32
+ "1cskvxk8z8vmfail8na7hj91hs0qnvds9nydj04zi3dbddgnbmvz"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-listen" ,ruby-listen)))
+ (synopsis
+ "Restarts your app when a file changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc.")
+ (description
+ "Restarts your app when a file changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc.")
+ (home-page "http://github.com/alexch/rerun/")
+ (license license:expat)))