aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-08-01 07:42:06 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 18:11:12 +0000
commit82ab22115748d4970058401b43ed1111baf14070 (patch)
tree2e0ba91a0341b65c66b7603628c1f1a0331dc75b
parentdec9dc7a627eaa893bfe43a04da666ff2150814b (diff)
downloadguix-82ab22115748d4970058401b43ed1111baf14070.tar
guix-82ab22115748d4970058401b43ed1111baf14070.tar.gz
gnu: Add ruby-github-api.
* gnu/packages/ruby.scm (ruby-github-api): New variable.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6b732233ee..c71405ea43 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2221,6 +2221,33 @@ use GNU gettext tools for maintenance.")
(home-page "https://ruby-gettext.github.com/")
(license (list license:lgpl3+ license:ruby))))
+(define-public ruby-github-api
+ (package
+ (name "ruby-github-api")
+ (version "0.18.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "github_api" version))
+ (sha256
+ (base32
+ "04x8mlvinl17wfw6r71c9jbh7g78ziiwvsqv20ylyjzybr7x0w6s"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-addressable" ,ruby-addressable)
+ ("ruby-descendants-tracker"
+ ,ruby-descendants-tracker)
+ ("ruby-faraday" ,ruby-faraday)
+ ("ruby-hashie" ,ruby-hashie)
+ ("ruby-oauth2" ,ruby-oauth2)))
+ (synopsis
+ " Ruby client that supports all of the GitHub API methods. It's build in a modular way, that is, you can either instantiate the whole api wrapper Github.new or use parts of it e.i. Github::Client::Repos.new if working solely with repositories is your main concern. Intuitive query methods allow you easily call API endpoints. ")
+ (description
+ " Ruby client that supports all of the GitHub API methods. It's build in a modular way, that is, you can either instantiate the whole api wrapper Github.new or use parts of it e.i. Github::Client::Repos.new if working solely with repositories is your main concern. Intuitive query methods allow you easily call API endpoints. ")
+ (home-page
+ "http://piotrmurach.github.io/github/")
+ (license license:expat)))
+
(define-public ruby-packnga
(package
(name "ruby-packnga")