aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-07-14 08:01:12 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 18:11:11 +0000
commit6f8c47a5fe4b5a69d577472a8049dffbc03e3fdd (patch)
tree650edbe9eeb2e0907f81d23845fb98d891177776
parent0557caae6959512b5b23377f4b54d715572ee646 (diff)
downloadguix-6f8c47a5fe4b5a69d577472a8049dffbc03e3fdd.tar
guix-6f8c47a5fe4b5a69d577472a8049dffbc03e3fdd.tar.gz
gnu: Add ruby-prometheus-client.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 191d441d57..49f85c3b3b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9679,3 +9679,25 @@ counters across multiple processes.")
(home-page
"http://github.com/matttproud/ruby_quantile_estimation")
(license license:asl2.0)))
+
+(define-public ruby-prometheus-client
+ (package
+ (name "ruby-prometheus-client")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "prometheus-client" version))
+ (sha256
+ (base32
+ "0ihbmnll7qkkhy5isd7vl3wrznyxm1havhzxhl8729im5qi6si51"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-quantile" ,ruby-quantile)))
+ (synopsis
+ "A suite of instrumentation metric primitivesthat can be exposed through a web services interface.")
+ (description
+ "This package provides a suite of instrumentation metric primitivesthat can be exposed through a web services interface.")
+ (home-page
+ "https://github.com/prometheus/client_ruby")
+ (license license:asl2.0)))