aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:47:20 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 12:29:21 +0000
commit6a6fa3fc982612469c644bc7b71ea26f5449eca7 (patch)
treeb2a9800340800cd725f576f332f18c747063402d
parent3d27c0b5813ab20a4bde11d01e0f0cf7abeb6c19 (diff)
downloadguix-6a6fa3fc982612469c644bc7b71ea26f5449eca7.tar
guix-6a6fa3fc982612469c644bc7b71ea26f5449eca7.tar.gz
gnu: Add ruby-coffee-script.
-rw-r--r--gnu/packages/ruby.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index beed61a399..588553bc7d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8705,3 +8705,42 @@ but it can function as a stand-alone templating engine.")
(home-page
"http://prawn.majesticseacreature.com")
(license #f)))
+
+(define-public ruby-coffee-script
+ (package
+ (name "ruby-coffee-script")
+ (version "2.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; fetch from github as the gem does not contain testing code
+ (uri (string-append
+ "https://github.com/rails/ruby-coffee-script/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gbcg40ks4ifm332ljmgq2l44ssld0z6xhjzk48v6mpaxyz8mc92"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-test
+ (lambda _
+ ;; patch submitted upstream at
+ ;; https://github.com/rails/ruby-coffee-script/pull/6
+ (substitute* "test/test_coffee_script.rb"
+ ((" unexpected unless\\\"")
+ " unexpected unless\", '[stdin]:3:11: unexpected unless'"))
+ #t)))))
+ (propagated-inputs
+ `(("ruby-coffee-script-source" ,ruby-coffee-script-source)
+ ("ruby-execjs" ,ruby-execjs)
+ ("ruby-duktape", ruby-duktape))) ; use as the JS interpreter
+ (synopsis "bridge to the javascript CoffeeScript compiler.")
+ (description
+ "Ruby CoffeeScript is a bridge to the javascript CoffeeScript compiler.
+CoffeeScript is an attempt to expose the good parts of JavaScript in a simple
+way.")
+ (home-page
+ "http://github.com/rails/ruby-coffee-script")
+ (license license:expat)))