aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:46:04 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 12:29:20 +0000
commit4cfb86335a4b2cf1d49e716318c78c51adb96fa6 (patch)
treed32c46aa6255852732416367e84c26acea6a53c6
parent3d99ee0914ae27edccc8590ef6a7b7381ddcecab (diff)
downloadguix-4cfb86335a4b2cf1d49e716318c78c51adb96fa6.tar
guix-4cfb86335a4b2cf1d49e716318c78c51adb96fa6.tar.gz
gnu: Add ruby-prawn.
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fcccc5ede5..e1b90e2226 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3403,6 +3403,38 @@ for select languages.")
(home-page "")
(license (list #f #f #f))))
+(define-public ruby-prawn
+ (package
+ (name "ruby-prawn")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "prawn" version))
+ (sha256
+ (base32
+ "0z9q3l8l73pvx6rrqz40xz9xd5izziprjnimb572hcah6dh30cnw"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Further dependencies such as pdf-inspector need to be
+ ; packaged.
+ (propagated-inputs
+ `(("ruby-pdf-core" ,ruby-pdf-core)
+ ("ruby-ttfunk" ,ruby-ttfunk)))
+ (synopsis
+ " Prawn is a fast, tiny, and nimble PDF generator for Ruby
+")
+ (description
+ " Prawn is a fast, tiny, and nimble PDF generator for Ruby
+")
+ (home-page
+ "http://prawn.majesticseacreature.com")
+ ;; Prawn is released under a slightly modified form of the License of Ruby,
+ ;; allowing you to choose between Matz's terms, the GPLv2, or GPLv3.
+ (license (list license:gpl2 license:gpl3
+ (license:non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution")))))
+
(define-public ruby-progress_bar
(package
(name "ruby-progress_bar")