aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:42:08 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 12:29:34 +0000
commit36648183ecf96aa0657a6fb19a9fa9ab4ff8877b (patch)
treee5109495f01ee2b865b5b7e6a285baacc834ae05
parentd3b525cbaa07b368384f1920c39a004813a04a24 (diff)
downloadguix-36648183ecf96aa0657a6fb19a9fa9ab4ff8877b.tar
guix-36648183ecf96aa0657a6fb19a9fa9ab4ff8877b.tar.gz
gnu: Add ruby-event-bus.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d9740c528c..34221c8b68 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1356,6 +1356,34 @@ support.")
(home-page "https://github.com/rails/execjs")
(license license:expat)))
+(define-public ruby-event-bus
+ (package
+ (name "ruby-event-bus")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "event-bus" version))
+ (sha256
+ (base32
+ "0bqcznr15q1346avpddnyd9144hqdww86yfpb4jayaj6lm0fqwyq"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; disable testing to break the cycle with aruba. Instead simply test that
+ ;; the library can be require'd.
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "ruby" "-Ilib" "-r" "event/bus")))))))
+ (synopsis
+ "This gem notifies subscribers about event")
+ (description
+ "This gem notifies subscribers about event")
+ (home-page
+ "https://github.com/cucumber/event-bus")
+ (license license:expat)))
+
(define-public ruby-orderedhash
(package
(name "ruby-orderedhash")