aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:25 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-28 18:11:11 +0000
commit199bcae42d58ea25247e4e5ad9710ed1de663608 (patch)
tree21330cd1016b4ba2aee1390840bb7c02713644ea
parent52700ba644ed7efd18419bf5d02d3e9b8e400a50 (diff)
downloadguix-199bcae42d58ea25247e4e5ad9710ed1de663608.tar
guix-199bcae42d58ea25247e4e5ad9710ed1de663608.tar.gz
gnu: Add ruby-jwt.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f9ce3887ee..d7d659dfe7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9446,3 +9446,24 @@ way.")
(home-page
"https://github.com/omniauth/omniauth-oauth2")
(license license:expat)))
+
+(define-public ruby-jwt
+ (package
+ (name "ruby-jwt")
+ (version "1.5.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jwt" version))
+ (sha256
+ (base32
+ "124zz1142bi2if7hl5pcrcamwchv4icyr5kaal9m2q6wqbdl6aw4"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "A pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
+ (description
+ "This package provides a pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
+ (home-page "http://github.com/jwt/ruby-jwt")
+ (license license:expat)))