aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:58 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commited5714a38df9a4aa4d92809f1fa0ab43dfc1cf9e (patch)
treed1fa8f94463a52927c17e3b6260de981fa8a0f37
parent0af7c8b2ecf344b2b1cd819b1b688c45f85a7e9d (diff)
downloadguix-ed5714a38df9a4aa4d92809f1fa0ab43dfc1cf9e.tar
guix-ed5714a38df9a4aa4d92809f1fa0ab43dfc1cf9e.tar.gz
gnu: Add ruby-unicode-display-width.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 84afa0b1e4..e6650f0921 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7017,3 +7017,25 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"https://github.com/JoshCheek/thread_order")
(license license:expat)))
+
+(define-public ruby-unicode-display-width
+(package
+ (name "ruby-unicode-display-width")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "unicode-display_width" version))
+ (sha256
+ (base32
+ "194d70pfxq4d7rrk0vsk1dvj46ns2f350308khi7q5cvnmg3h1xs"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; test data not included in gem.
+ (synopsis
+ "[Unicode 1.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.")
+ (description
+ "[Unicode 1.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.")
+ (home-page
+ "http://github.com/janlelis/unicode-display_width")
+ (license license:expat)))