aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:40:40 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 10:50:32 +0100
commitd8ccb4e67f91ee381ec9f4f27777de3dbaaba477 (patch)
tree245584f81409b1e584469a5877bcd889971e5a6f
parent6ac52e098a284f2a4b3fc1ec93c79355f69f35b6 (diff)
downloadguix-d8ccb4e67f91ee381ec9f4f27777de3dbaaba477.tar
guix-d8ccb4e67f91ee381ec9f4f27777de3dbaaba477.tar.gz
gnu: Add ruby-multi-json.
-rw-r--r--gnu/packages/ruby.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 00b51cb24e..58b3760da3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5047,3 +5047,42 @@ in standard Ruby syntax.")
"The fastest JSON parser and object serializer. ")
(home-page "http://www.ohler.com/oj")
(license license:expat)))
+
+(define-public ruby-multi-json
+ (package
+ (name "ruby-multi-json")
+ (version "1.11.2")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Tests are not distributed at rubygems.org so download from GitHub
+ ;; instead.
+ (uri (string-append "https://github.com/intridea/multi_json/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04vkfz88vj6ab3097n0xgm0335j753ik03zkq44grq6m36m94vk5"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-signing-key-reference
+ (lambda _
+ (substitute* "multi_json.gemspec"
+ ((".*spec.signing_key.*") ""))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-yard" ,ruby-yard)
+ ("ruby-json-pure" ,ruby-json-pure)
+ ("ruby-oj" ,ruby-oj)
+ ("ruby-yajl-ruby" ,ruby-yajl-ruby)))
+ (synopsis
+ "A common interface to multiple JSON libraries, including Oj, Yajl, the JSON gem (with C-extensions), the pure-Ruby JSON gem, NSJSONSerialization, gson.rb, JrJackson, and OkJson.")
+ (description
+ "A common interface to multiple JSON libraries, including Oj, Yajl, the JSON gem (with C-extensions), the pure-Ruby JSON gem, NSJSONSerialization, gson.rb, JrJackson, and OkJson.")
+ (home-page
+ "http://github.com/intridea/multi_json")
+ (license license:expat)))