aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:49:49 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commitd6f5f562216eae70488dfacd52e7205e1c4ea62d (patch)
treed418a0cd0d53b6d5a0fdfd6c423658b371c36f76
parente58fddf995a36d6f5001bf7412e74b9be7f916b6 (diff)
downloadguix-d6f5f562216eae70488dfacd52e7205e1c4ea62d.tar
guix-d6f5f562216eae70488dfacd52e7205e1c4ea62d.tar.gz
gnu: Add ruby-backports.
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5b3649c165..103fa6e5ae 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6486,3 +6486,23 @@ than closing tags. It was originally envisioned as a plugin for Ruby on Rails,
but it can function as a stand-alone templating engine.")
(home-page "http://haml.info/")
(license license:expat)))
+
+(define-public ruby-backports
+ (package
+ (name "ruby-backports")
+ (version "3.6.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "backports" version))
+ (sha256
+ (base32
+ "0m8jkjh4kymgfipd6yb0zcxlas4x5r60k2c94zkklb1ryma33grc"))))
+ (build-system ruby-build-system)
+ (synopsis
+ "Essential backports that enable many of the nice features of Ruby 1.8.7 up to 2.1.0 for earlier versions.")
+ (description
+ "Essential backports that enable many of the nice features of Ruby 1.8.7 up to 2.1.0 for earlier versions.")
+ (home-page
+ "http://github.com/marcandre/backports")
+ (license license:expat)))