aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym+a@scratchpost.org>2016-07-20 11:33:32 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-22 15:06:05 +0200
commitc2f0dc6ed186be77f718c8016bcb8a5c008a1a8e (patch)
tree75eef3883b4624fc78cb3037b66b0535b9f1db0b
parent654c0d97c9de4bf25b9facda1278835883555ae0 (diff)
downloadguix-c2f0dc6ed186be77f718c8016bcb8a5c008a1a8e.tar
guix-c2f0dc6ed186be77f718c8016bcb8a5c008a1a8e.tar.gz
gnu: Add ptpython and ptpython2.
* gnu/packages/python.scm (ptpython, ptpython-2): New variables. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f534dd0e30..208ae03a8e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9748,3 +9748,36 @@ characters, mouse support, and auto suggestions.")
(native-inputs
`(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs base))))))
+
+(define-public ptpython
+ (package
+ (name "ptpython")
+ (version "0.34")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ptpython" version))
+ (sha256
+ (base32
+ "1mmbiyzf0n8hm7z2a562x7w5cbl6jc0zsk6vp40q1z4cyblv1k13"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-docopt" ,python-docopt)
+ ("python-jedi" ,python-jedi)
+ ("python-prompt-toolkit" ,python-prompt-toolkit)
+ ("python-pygments" ,python-pygments)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/jonathanslenders/ptpython")
+ (synopsis "Python Read-Eval-Print-Loop with nice IDE-like features")
+ (description
+ "ptpython is a Python read-eval-print loop with IDE-like features.
+It supports syntax highlighting, multiline editing, autocompletion, mouse,
+color schemes, bracketed paste, Vi and Emacs keybindings, Chinese characters
+etc.")
+ (license bsd-3)
+ (properties `((python2-variant . ,(delay ptpython-2))))))
+
+(define-public ptpython-2
+ (let ((base (package-with-python2 (strip-python2-variant ptpython))))
+ (package
+ (inherit base)
+ (name "ptpython2"))))