aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 12:00:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:40 +0100
commitc0a541cba8cdc33d3420bfc17da022de5a2a07c6 (patch)
treeda9c5dbdec285d5732b473cfae11d2d7f664b5c9
parenta49bb332a1e0a66ccd8dcc01902997c2d996ae31 (diff)
downloadguix-c0a541cba8cdc33d3420bfc17da022de5a2a07c6.tar
guix-c0a541cba8cdc33d3420bfc17da022de5a2a07c6.tar.gz
gnu: ghc-fgl: Fix build with newer QuickCheck.
* gnu/packages/haskell.scm (ghc-fgl)[arguments]: Allow building with newer QuickCheck.
-rw-r--r--gnu/packages/haskell.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ea83dea397..85513b5491 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3169,6 +3169,8 @@ variety of traversals.")
(base32
"0fbyb6jxy9whgrv6dgnkzz70cmy98arx3q2gnkhgl4a3d7idh36p"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:configure-flags (list "--allow-newer=QuickCheck")))
(inputs
`(("ghc-mtl" ,ghc-mtl)
("ghc-hspec" ,ghc-hspec)