aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-18 22:15:31 +0000
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commita604be516293b307616a726f600e56fa232cfa45 (patch)
treeb2c3d24ca4c1329f54a89bf19ed51f2372d452b0
parent850c4ad42d1217ed89712cd5d29ff0c9aba15689 (diff)
downloadguix-a604be516293b307616a726f600e56fa232cfa45.tar
guix-a604be516293b307616a726f600e56fa232cfa45.tar.gz
gnu: Add ruby-ref.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4e75afbe69..e3da4c3cf6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6288,3 +6288,33 @@ CoffeeScript is released.")
(home-page
"https://github.com/judofyr/duktape.rb")
(license license:expat)))
+
+(define-public ruby-ref
+(package
+ (name "ruby-ref")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Tests are not distributed at rubygems.org so download from GitHub
+ ;; instead.
+ (uri (string-append "https://github.com/ruby-concurrency/ref/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1090z8vzf8bf7gx3akvrn4alcklyanbg6hipjmzlzkx0lr1l5zj4"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"))
+ (synopsis
+ "Library that implements weak, soft, and strong references in Ruby that work
+across multiple runtimes (MRI, Jruby and Rubinius). Also includes implementation
+of maps/hashes that use references and a reference queue.")
+ (description
+ "Library that implements weak, soft, and strong references in Ruby that work
+across multiple runtimes (MRI, Jruby and Rubinius). Also includes
+implementation of maps/hashes that use references and a reference queue.")
+ (home-page
+ "http://github.com/ruby-concurrency/ref")
+ (license license:expat)))