aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:43:40 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:02 +0100
commita2f8721dd1d4491a9c5751030920be3be460e084 (patch)
treea270de839e8dbf00b2112bb49d46f45193ea9d5f
parent94f9c12e978c12294b6fa01bcf3a3b3144b448fd (diff)
downloadguix-a2f8721dd1d4491a9c5751030920be3be460e084.tar
guix-a2f8721dd1d4491a9c5751030920be3be460e084.tar.gz
gnu: Add ruby-coveralls.
-rw-r--r--gnu/packages/ruby.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index dc9bb886da..5234479117 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5560,3 +5560,56 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
"Radius is a powerful tag-based template language for Ruby inspired by the template languages used in MovableType and TextPattern. It uses tags similar to XML, but can be used to generate any form of plain text (HTML, e-mail, etc...).")
(home-page "http://github.com/jlong/radius")
(license #f)))
+
+(define-public ruby-coveralls
+ (package
+ (name "ruby-coveralls")
+ (version "0.8.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "coveralls" version))
+ (sha256
+ (base32
+ "1y6gzahhaymgcxcgm7y16sgbiafsb7i2flhy1sq4x1jizk8bih5s"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'extract-gemspec 'update-dependency
+ (lambda _
+ ;; Relax dependency to avoid conflicting versions in nio4r
+ ;; for instance.
+ (substitute* "coveralls-ruby.gemspec"
+ (("<simplecov.*") "<simplecov>)\n")
+ (("<tins.*") "<tins>)\n"))
+
+ #t))
+ (add-before 'check 'fix-dependencies
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ ((".*pry.*") "\n"))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-truthy" ,ruby-truthy)
+ ("ruby-webmock" ,ruby-webmock)
+ ("ruby-vcr" ,ruby-vcr)
+ ("git" ,git))) ; git is required for testing
+ (propagated-inputs
+ `(("ruby-json" ,ruby-json)
+ ("ruby-rest-client" ,ruby-rest-client)
+ ("ruby-simplecov" ,ruby-simplecov)
+ ("ruby-term-ansicolor" ,ruby-term-ansicolor)
+ ("ruby-thor" ,ruby-thor)
+ ("ruby-simplecov" ,ruby-simplecov)
+ ("ruby-tins" ,ruby-tins)))
+ (synopsis
+ "A Ruby implementation of the Coveralls API.")
+ (description
+ "A Ruby implementation of the Coveralls API.")
+ (home-page "https://coveralls.io")
+ (license license:expat)))