aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:47:20 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:02 +0100
commit99dff2528987e6da032e88ad5e112215922dc1ea (patch)
treeada4f6b8fd2886c982431c76d7d064cae2c8befa
parentee7ce2627dff3f852f4126b5c418ec7a5badd862 (diff)
downloadguix-99dff2528987e6da032e88ad5e112215922dc1ea.tar
guix-99dff2528987e6da032e88ad5e112215922dc1ea.tar.gz
gnu: Add ruby-coffee-script.
-rw-r--r--gnu/packages/ruby.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d1d1db6860..11e4b7dfc7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6152,3 +6152,42 @@ using a strict syntax definition and supporting several common extensions.
"Run any kind of code in parallel processes")
(home-page "https://github.com/grosser/parallel")
(license license:expat)))
+
+(define-public ruby-coffee-script
+ (package
+ (name "ruby-coffee-script")
+ (version "2.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; fetch from github as the gem does not contain testing code
+ (uri (string-append
+ "https://github.com/rails/ruby-coffee-script/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gbcg40ks4ifm332ljmgq2l44ssld0z6xhjzk48v6mpaxyz8mc92"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-test
+ (lambda _
+ ;; patch submitted upstream at
+ ;; https://github.com/rails/ruby-coffee-script/pull/6
+ (substitute* "test/test_coffee_script.rb"
+ ((" unexpected unless\\\"")
+ " unexpected unless\", '[stdin]:3:11: unexpected unless'"))
+ #t)))))
+ (propagated-inputs
+ `(("ruby-coffee-script-source" ,ruby-coffee-script-source)
+ ("ruby-execjs" ,ruby-execjs)
+ ("ruby-duktape", ruby-duktape))) ; use as the JS interpreter
+ (synopsis "bridge to the javascript CoffeeScript compiler.")
+ (description
+ "Ruby CoffeeScript is a bridge to the javascript CoffeeScript compiler.
+CoffeeScript is an attempt to expose the good parts of JavaScript in a simple
+way.")
+ (home-page
+ "http://github.com/rails/ruby-coffee-script")
+ (license license:expat)))