aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:35:19 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 10:50:32 +0100
commit93d16c913dc6200a99a2c22f6fcd2d013ac55476 (patch)
tree793ef3a60b3b73a3b6e4e5f0f3d1206b5c8ceb9d
parent5a81f56783c256fa0617e6bf47ea38f643f045fd (diff)
downloadguix-93d16c913dc6200a99a2c22f6fcd2d013ac55476.tar
guix-93d16c913dc6200a99a2c22f6fcd2d013ac55476.tar.gz
gnu: Add ruby-addressable.
* gnu/packages/ruby.scm (ruby-addressable): New variable.
-rw-r--r--gnu/packages/ruby.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2ebb03526d..36d96caafb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5193,3 +5193,47 @@ value of an attribute. For example, one can use @code{its(:size)\\{should
eq(1)\\}}.")
(home-page "https://github.com/rspec/rspec-its")
(license license:expat)))
+
+(define-public ruby-addressable
+ (package
+ (name "ruby-addressable")
+ (version "2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "addressable" version))
+ (sha256
+ (base32
+ "0mpn7sbjl477h56gmxsjqb89r5s3w7vx5af994ssgc3iamvgzgvs"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-rakefile
+ (lambda _
+ (substitute* "Gemfile"
+ (("git: 'https://github.com/sporkmonger/rack-mount.git',") "")
+ ((".*launchy.*") "")
+ ((".*redcarpet.*") ""))
+ #t))
+ (add-before 'check 'delete-network-test
+ (lambda _
+ (delete-file "spec/addressable/net_http_compat_spec.rb")
+ #t)))))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)
+ ("bundler" ,bundler)
+ ("ruby-sporkmonger-rack-mount" ,ruby-sporkmonger-rack-mount)
+ ("ruby-rspec-its", ruby-rspec-its)
+ ("ruby-yard" ,ruby-yard)
+ ("ruby-simplecov" ,ruby-simplecov)))
+ (synopsis "Uniform resource identifier (URI) reimplementation")
+ (description
+ "Addressable is a replacement for the URI implementation that is part of
+Ruby's standard library. It more closely conforms to the relevant RFCs and
+adds support for IRIs and URI templates.")
+ (home-page
+ "https://github.com/sporkmonger/addressable")
+ (license license:asl2.0)))