aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:53:45 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:03 +0100
commit88bd8f8f9a69022940954448fdc4ef5860cf0c83 (patch)
treeccc3a324289dde23beb4b3ac74ec12cc4647130e
parent1cde2c0a9fc6d8fe50c4c20ccd602e502647b593 (diff)
downloadguix-88bd8f8f9a69022940954448fdc4ef5860cf0c83.tar
guix-88bd8f8f9a69022940954448fdc4ef5860cf0c83.tar.gz
gnu: Add ruby-nio4r.
-rw-r--r--gnu/packages/ruby.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0b0319f682..96db1b08ea 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6659,3 +6659,39 @@ minutes of work.
(home-page
"https://github.com/travis-ci/travis.rb")
(license license:expat)))
+
+(define-public ruby-nio4r
+ (package
+ (name "ruby-nio4r")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "nio4r" version))
+ (sha256
+ (base32
+ "0jjrj7vs29w6dfgsxq08226jfbi2j0x62lf4p9zmvyp19dj4z00a"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-dependencies
+ (lambda _
+ (substitute* "Gemfile"
+ (("rubocop.*") "rubocop\"\n"))
+ #t))
+ (add-before 'check 'compile
+ (lambda _
+ (zero? (system* "rake" "compile")))))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-rubocop" ,ruby-rubocop)
+ ("ruby-coveralls" ,ruby-coveralls)))
+ (synopsis "New IO for Ruby")
+ (description "New IO for Ruby")
+ (home-page "https://github.com/celluloid/nio4r")
+ (license license:expat)))