aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:42:08 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 10:50:32 +0100
commit8716eb84e40ab8657a25f0aee21835793fb484b2 (patch)
tree21cdb5bd8ffc705c841282f61b569468024fa463
parenta5026b489d8f3cae4fa78f5152047d5652a2d0c1 (diff)
downloadguix-8716eb84e40ab8657a25f0aee21835793fb484b2.tar
guix-8716eb84e40ab8657a25f0aee21835793fb484b2.tar.gz
gnu: Add ruby-event-bus.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 884da90f26..189f5f3f63 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5418,3 +5418,31 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
(home-page
"http://github.com/egonSchiele/contracts.ruby")
(license #f)))
+
+(define-public ruby-event-bus
+ (package
+ (name "ruby-event-bus")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "event-bus" version))
+ (sha256
+ (base32
+ "0bqcznr15q1346avpddnyd9144hqdww86yfpb4jayaj6lm0fqwyq"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; disable testing to break the cycle with aruba. Instead simply test that
+ ;; the library can be require'd.
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "ruby" "-Ilib" "-r" "event/bus")))))))
+ (synopsis
+ "This gem notifies subscribers about event")
+ (description
+ "This gem notifies subscribers about event")
+ (home-page
+ "https://github.com/cucumber/event-bus")
+ (license license:expat)))