aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:41:47 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 10:50:32 +0100
commit82c8b97fa59b30b0344132562cb75a08b6412dbe (patch)
treec9a1f0987e7237a6aebd17d0b3c83e28b4b75ba8
parent15dc45f4649ca13dd36b41c2231b579e9a2edcad (diff)
downloadguix-82c8b97fa59b30b0344132562cb75a08b6412dbe.tar
guix-82c8b97fa59b30b0344132562cb75a08b6412dbe.tar.gz
gnu: Add ruby-fuubar.
-rw-r--r--gnu/packages/ruby.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4dea344f7e..7485d09478 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5342,3 +5342,43 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
(home-page
"https://github.com/jfelchner/ruby-progressbar")
(license license:expat)))
+
+(define-public ruby-fuubar
+ (package
+ (name "ruby-fuubar")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The gem does not include files required for testing.
+ (uri (string-append "https://github.com/thekompanee/fuubar/archive/releases/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1363fy7x12srr51cy5x1xkf9z7jlzzlwpsifwgx6bivnp6lar3ny"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f ; some tests fail when running (zero? (system* "rspec"
+ ; "-Ilib" "spec")) inside the container, but seem to work outside.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'delete-certificate
+ (lambda _
+ ;; Remove 's.cert_chain' as we do not build with a private key
+ (substitute* "fuubar.gemspec"
+ ((".*cert_chain.*") "")
+ ((".*signing_key.*") ""))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (propagated-inputs
+ `(("ruby-rspec" ,ruby-rspec)
+ ("ruby-ruby-progressbar" ,ruby-ruby-progressbar)))
+ (synopsis
+ "the instafailing RSpec progress bar formatter")
+ (description
+ "the instafailing RSpec progress bar formatter")
+ (home-page
+ "https://github.com/thekompanee/fuubar")
+ (license license:expat)))