aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-02 14:39:03 -0400
committerLeo Famulari <leo@famulari.name>2016-10-05 17:41:44 -0400
commit7d4536568417796a8c697b30b464b727d46cee8d (patch)
treef0a786520cfebec62428e159d2d20f3825ffb2cc
parent87312f8aa1a24bfb072496ac845683fdbee3faa4 (diff)
downloadguix-7d4536568417796a8c697b30b464b727d46cee8d.tar
guix-7d4536568417796a8c697b30b464b727d46cee8d.tar.gz
gnu: e2fsprogs: Disable parallel build.
* gnu/packages/linux.scm (e2fsprogs)[arguments]: Add #:parallel-build? #f.
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 42fadb926f..c9740ecbfc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -595,7 +595,11 @@ slabtop, and skill.")
(native-inputs `(("pkg-config" ,pkg-config)
("texinfo" ,texinfo))) ;for the libext2fs Info manual
(arguments
- '(;; util-linux is the preferred source for some of the libraries and
+ '(;; Parallel building reliably yields a failure like this:
+ ;; "make[2]: *** No rule to make target '../lib/libss.so', needed by
+ ;; 'debufs'. Stop."
+ #:parallel-build? #f
+ ;; util-linux is the preferred source for some of the libraries and
;; commands, so disable them (see, e.g.,
;; <http://git.buildroot.net/buildroot/commit/?id=e1ffc2f791b33633>.)
#:configure-flags '("--disable-libblkid"