aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-27 01:24:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-27 21:04:39 +0100
commit7d24c26ed7b67ce1220fee9e5df99d74cb5346e7 (patch)
tree8e0d7f04b51438949e175ce2d96ad8ac7a29204f
parentb82d5b09ff815f638a3a78fec59eec469f6ab386 (diff)
downloadguix-7d24c26ed7b67ce1220fee9e5df99d74cb5346e7.tar
guix-7d24c26ed7b67ce1220fee9e5df99d74cb5346e7.tar.gz
gnu: girara: Enable tests.
* gnu/packages/gtk.scm (girara)[native-inputs]: Add XORG-SERVER. [arguments]: Add START-XSERVER phase. Remove #:tests?.
-rw-r--r--gnu/packages/gtk.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 1b662226fb..22343c923e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -16,6 +16,7 @@
;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Coypright © 2017 Roel Janssen <roel@gnu.org>
;;; Coypright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Coypright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1249,7 +1250,8 @@ write GNOME applications.")
(native-inputs `(("pkg-config" ,pkg-config)
("check" ,check)
("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")))
+ ("glib:bin" ,glib "bin")
+ ("xorg-server" ,xorg-server)))
;; Listed in 'Requires.private' of 'girara.pc'.
(propagated-inputs `(("gtk+" ,gtk+)))
(arguments
@@ -1257,9 +1259,18 @@ write GNOME applications.")
`(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
"COLOR=0" "CC=gcc")
#:test-target "test"
- #:tests? #f ; Tests fail with "Gtk cannot open display:"
- #:phases
- (modify-phases %standard-phases (delete 'configure))))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'check 'start-xserver
+ ;; Tests require a running X server.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xorg-server (assoc-ref inputs "xorg-server"))
+ (display ":1"))
+ (setenv "DISPLAY" display)
+ ;; Don't fail due to missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (zero? (system (string-append xorg-server "/bin/Xvfb "
+ display " &")))))))))
(build-system gnu-build-system)
(home-page "https://pwmt.org/projects/girara/")
(synopsis "Library for minimalistic gtk+3 user interfaces")