aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:45:41 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:02 +0100
commit703746ec0e54d77c2daf41517368f28a6dcd4a51 (patch)
tree63b8f6af40ab788c8870414d66ab5a3b8cd7e3c6
parentadde419cd642069594b38adad3adc2c1cd94b03c (diff)
downloadguix-703746ec0e54d77c2daf41517368f28a6dcd4a51.tar
guix-703746ec0e54d77c2daf41517368f28a6dcd4a51.tar.gz
gnu: Add ruby-appraisal.
-rw-r--r--gnu/packages/ruby.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7bbf64f284..448641faa9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5931,3 +5931,42 @@ will probably be an issue and hence this gem.")
(home-page
"https://github.com/janlelis/ruby_version")
(license license:expat)))
+
+(define-public ruby-appraisal
+ (package
+ (name "ruby-appraisal")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "appraisal" version))
+ (sha256
+ (base32
+ "10ng010lhswdykjhwic7bgv28qpjj42qwxvprpj1f4cavdimh4vp"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f ; tests require network access
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ ;; remove bundler from Rakefile to avoid dependency issues
+ (add-before 'check 'remove-dependency-checking
+ (lambda _
+; (substitute* "Rakefile"
+ ; (("^require 'bundler.*") ""))
+ (substitute* "Gemfile"
+ (("thor.*") "thor'\n"))
+ #t)))))
+ (propagated-inputs
+ `(("bundler" ,bundler)
+ ("ruby-thor" ,ruby-thor)))
+ (native-inputs
+ `(("ruby-activesupport" ,ruby-activesupport)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis
+ "Appraisal integrates with bundler and rake to test your library against different versions of dependencies in repeatable scenarios called \"appraisals.\"")
+ (description
+ "Appraisal integrates with bundler and rake to test your library against different versions of dependencies in repeatable scenarios called \"appraisals.\"")
+ (home-page
+ "http://github.com/thoughtbot/appraisal")
+ (license license:expat)))