aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:40:49 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 10:50:32 +0100
commit6ac52e098a284f2a4b3fc1ec93c79355f69f35b6 (patch)
treeb1718b5159cb796a58e99897b5614d685acea072
parentcc5aaaa7ff1e0a91b024fad2765bdf9e67f06173 (diff)
downloadguix-6ac52e098a284f2a4b3fc1ec93c79355f69f35b6.tar
guix-6ac52e098a284f2a4b3fc1ec93c79355f69f35b6.tar.gz
gnu: Add ruby-oj.
-rw-r--r--gnu/packages/ruby.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 07f1a01b87..00b51cb24e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5014,3 +5014,36 @@ in standard Ruby syntax.")
(home-page
"http://github.com/brianmario/yajl-ruby")
(license license:expat)))
+
+(define-public ruby-oj
+ (package
+ (name "ruby-oj")
+ (version "2.18.5")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Version on rubygems.org does not contain Rakefile, so download from
+ ;; GitHub instead.
+ (uri (string-append "https://github.com/ohler55/oj/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0mkg70j0f40910rji64q9yfpy7zp46ny5bhfhjax4ik1pg361cgw"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'compile
+ (lambda _
+ (zero? (system* "rake" "compile")))))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis
+ "The fastest JSON parser and object serializer. ")
+ (description
+ "The fastest JSON parser and object serializer. ")
+ (home-page "http://www.ohler.com/oj")
+ (license license:expat)))