aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:44:10 +0100
committerChristopher Baines <mail@cbaines.net>2018-05-18 11:54:02 +0100
commit6801ddeccfd4a8f83800b2508af11550cbdaf7bc (patch)
treeab1af16067e28e783f45a82d719600b6726ba72b
parent9974fbbfcbed7b44bbe1df7372ca5fee445f338f (diff)
downloadguix-6801ddeccfd4a8f83800b2508af11550cbdaf7bc.tar
guix-6801ddeccfd4a8f83800b2508af11550cbdaf7bc.tar.gz
gnu: Add ruby-webmock.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 160921c78a..ff00a898a4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5703,3 +5703,30 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
(home-page
"https://github.com/liufengyun/hashdiff")
(license license:expat)))
+
+(define-public ruby-webmock
+ (package
+ (name "ruby-webmock")
+ (version "1.22.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "webmock" version))
+ (sha256
+ (base32
+ "0la47vzbikhvnx8qcj8jli87agzzffwh11ggm7rpq43iz2rwp0sl"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("bundler" ,bundler)
+ ("ruby-addressable" ,ruby-addressable)
+ ("ruby-crack" ,ruby-crack)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-hashdiff" ,ruby-hashdiff)))
+ (synopsis
+ "WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.")
+ (description
+ "WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.")
+ (home-page "http://github.com/bblimke/webmock")
+ (license license:expat)))